E2Studio 6 build variables

Hi all,

I'm trying out e2studio 6.0. I had a e2studio 5.4 project for RX23T. The update was almost painless, but there is one blocking problem:

build variables, although they appear to be present, don't seem to be visible to e2studio.

I'm using a bunch on build variables that contain the software version, and they are used in two ways:

- to compose a build artifact containing the version number

- to define macros with the same name at compiler's command line

None of these things work.


To explain better what I mean:

I've defined these build variables:

V1 with a value of 0

V2 with a value of 1

V3 with a value of 3

V4 with a value of 0

I've defined the following macros in the "symbols" tab:

V1 with a value of ${V1}

V2 with a value of ${V2}

V3 with a value of ${V3}

V4 with a value of ${V4}

The build artifact is defined as:


I would expect a compiler command line containing:


and a build artifact called "MyFirmware_V0.1.3.0"

What I get, instead is:


And a build artifact called "MyFirmware_V..."

All these things worked perfectly with e2studio 5.4


Any ideas?



  • Any news for this topic?

    Moreover I'm not able to use build variables in the command line for build steps which worked perfectly with e2studio 5.4. For example both "${env_var:VCINSTALLDIR}" and "${workspace_loc:/${ProjName}/SourceGen.mak}" is resolved to none.


  • I am also unable to use V6. It can not find my linker file for the same reason.
  • Giovani

    I setup a simple test between 5.4 and 6.0 to see the behavior using your description and setup.

    In 5.4, I see the build artifact created just as you described.

    I imported the project to 6.0 and the settings were lost, however the build artifact was still created-strange.

    Is this the behavior you are seeing or is the build artifact with the correct symbols output in the console of 6.0?

  • In reply to twelvexs:


    I noticed too that some settings were lost. Anyway, I restored at least the build variables I needed and the build artifact. What I saw is that on the console the build artifact was created with a series of dots, because the numbers that should have been between the dots were missing.

  • In reply to jive74:


    This is what I saw as well.

    I will report this to the developers so they are aware of the issue.

  • In reply to jive74:

    Has your issue been resolved?

    Mike Clements
    RenesasRulz Moderator
  • This thread will be archived due to inactivity.

    Mike Clements
    RenesasRulz Moderator