RL78 debugging

 What would prevent me from debugging my RL78 target board when I can programme it without error with the E1 emulator. I'm aware of IDs, mine are set at all zeroes.

The pins are configured as per the eval board with TReset and Reset present.



  • Have you enabled debugging in the option bytes (bit 7 at address 0x00C3)? This bit is ONLY used for debugging.
  • In reply to FrankL:

    The debug bit is set. This is the GDB command line

    Starting server with the following options:

           Raw options                : C:\Renesas\e2_studio\eclipse\../DebugComp/e2-server-gdb -g E1 -t R5F101FJ -v -p 61234 -d 61236 -umFreq= 0 -usFreq= 0 -umClock= 1 -w 0 -usupplyVoltage= 0 -ucommMethod= 0 -usecurityID= 00000000000000000000 -upermitFlash= 1 -uuseWideVoltageMode= 1 -ueraseRom= 1 -uuseOnChipDebug= 0 -uuseUserOptionByte= 0 -ustopTimerEmu= 0 -ustopSerialEmu= 0 -umaskInternalResetSignal= 0 -umaskTargetResetSignal= 0 -n 0 -uverifyOnWritingMemory= 1 -uTraceCapture= 0 --english

    Warning: Rejecting illegal command line argument 7: 61234

    Connecting to E1/E20, RL78 Target

           GDBServer endian           : little

           Target power               : off

    Starting target connection

  • In reply to harrier:

    I had a load of problems with connecting, as you had seen a program would work fine, but connecting to the system was hit and miss, with nearly 100% miss.
    I'm mostly certain my issues was the length of the cabling I had, originally I had the 14pin from E1 to a adapter-protoboard to do the wiring, then from adapter-protoboard on about 30cm of cabling to probably 50cm of cabling for the on board programming connector.
    I connected the adapter-protoboard directly to the test unit and found I could program and debug.
    I then went back to the original setup and tried again, programming fine, debugging failure.
    In the flash programmer I upped the communication rate to the higher value and tried programming which then failed. I removed the extra cabling and tried again, flash programming worked (and debug again too).
    My assumption is that GDB debugging is using the highest communication rate which for longer cable lengths is susceptible to intrinsic capacitance (ironically, I used larger gauge wires on the adapter board which may actually increase capacitance) in the cable lengths.
    Try the test in the Flash programmer with the higher rate and see if this fails, if so then reduce the cable length (even temporarily) and try again. If it now works then you have your answer, if not a solution.
    The fix at this time would be to reduce the cable lengths (not necessarily easy to do), I can't find the voodoo to get eclipse or GDB components to use a different connection speed.

    Renesas need to sort their documentation out for the GDB side, I can't find the command line parameters anywhere and the error codes reported are also not documented. The exe is also a pain as it kills the console that started it every time. The E1/E20 GDB debugging appears slap dash.
  • harrier,

    Have you found a solution to your issue?

    Mike Clements
    RenesasRulz Moderator
  • In reply to stevea73:

    This thread will be archived due to inactivity.

    Mike Clements
    RenesasRulz Moderator