"Could not determine GBD version" launch error

Upon launching the debugger I get a dialog with:

     Exception occurred during launch

     Reason:

     Could not determine GBD version using command:

     C:\Renesas\e2_studio\DebugComp\arm-none-eabi-gbd --version

 This occurs after I had to reset my Windows 10. I did reinstall E2Studio and the SSP.

 

  • I saved my previous e2studio folder. When using that folder, when I hit the "Debug" bug icon, no message, dialog or action appears. The only thing that does happen is a flash in the console window. Looking closely the default title ("Synergy") is rapidly replaced by 2 lines and than back to "Synergy". One line has the words "... to display at this time", the other line has "... GDB Hardware Debugging] gbd traces".

    I already tried reinstalling E2Studio once more. E2Studio never appeared in the Windows 10 Start Menu.

    Errors like this do not instill confidence.

    I guess the thing to do is to radically wipe E2 from my disk and start over. How do I fully remove E2? I do mean fully, not just a "uninstall".
  • In reply to nick:

    Hi nick,

    the first thing I have noticed is a typo - it should be: arm-none-eabi-gdb.

    Could you check what is the value set in:
    e2 studio > menu Run > Debug Configurations > Renesas GDB Hardware Debugging > [your_project_name] > Debugger tab > GDB Command

    Please also verify what is the result returned when you execute this command in command line. To do that please:

    1. in the Windows Command Prompt navigate to the e2 studio installation directory, i.e. C:\Renesas\e2_studio\DebugComp
    2. type: arm-none-eabi-gdb.exe --version

    To uninstall e2 studio I use the uninstaller:
    <e2_studio_inst_dir>\uninstall\uninstall.exe
    Then I remove the <e2_studio_inst_dir> directory manually if necessary.

    Best regards,
    anper

  • In reply to nick:

    I did 2 more reinstalls. I made a post about the first one, left it as a draft, and this forum, kindly, wiped it when I came back to it. The summary: in Debug Configuration, Debugger tab, there was no Debugger configured. At all. It did request I point it to the license file.

    So I uninstalled, again. Wiped the C:\Renesas folder, then reinstalled E2 (with only Synergy marked), then SSP1.30, then ran E2Studio, confirming integration of GCC. I do not remember seeing a request for the license file. Project compiles OK, as ever. But I am back to the original post: "Could not determine GBD version".

    Install do not seem to be deterministic.
  • In reply to anper:

    > the first thing I have noticed is a typo - it should be: arm-none-eabi-gdb.

    That typo was mine. I was copying from a dialog that does NOT allow selection :(

    Going to do one more reinstall.
  • In reply to anper:

    > type: arm-none-eabi-gdb.exe --version

    I opened a cmd.exe in the folder that contains "arm-none-eabi-gdb.exe" and ran the command "type: arm-none-eabi-gdb.exe --version". Result (translated):

    "The application could not be started correctly (0xc0000022). Click OK to close the application".
  • In reply to nick:

    Nick,

    the result of "type: arm-none-eabi-gdb.exe --version" which you posted is definitely showing there is something wrong.

    Could you post here a screenshot of the following settings:
    e2 studio > menu Project > Properties > C/C++ Build > Settings > Toolchain tab

    Best regards,
    anper

  • In reply to anper:

    Seems my windows continues corrupted :/

    Thank you.
  • In reply to nick:

    Hi Nick,

    could you also check what toolchain is integrated with e2 studio?
    e2 studio > menu Help > Add Renesas Toolchains

    Please also verify what result you get by executing commands:

    • arm-none-eabi-gdb.exe --version
    • arm-none-eabi-gcc.exe --version

    in the C:\Program Files (x86)\GNU Tools ARM Embedded\4.9 2015q3\bin directory.

    I tried to find what is the meaning of "The application was unable to start correctly (0xc0000022)" error message. It seems it can be caused by incorrect permissions to a particular file, typically some .dll file(s) in Windows.

    Best regards,
    anper

  • In reply to nick:

    I did a full reinstall of Windows 10. Then I installed E2Studio, had it create a group in the start menu, but no group was created in the Start Menu... again.

    Initially there was no debugger in Debug Configurations, but that was resolved after installing the SSP. Does not make sense to me, but at least it is now working.

    Thanks again.