Unable to clean project

Other than some other odd behavior, I am noticing that I cannot clean my project.  Error mentions about cygwin.dll, but could not locate in my c folder where e2 studio is installed.  Do I need to do a complete uninstall & reinstall?


  • Uninstalled and reinstalled E2studio. Still unable to clean project(s)
  • In reply to jimctr:


    Maybe too obvious an option, but have you tried (re-)installing cygwin? You can get it from https://www.cygwin.com/

  • Thanks for the suggestion. Didn't resolve the problem though. Also ran a registry clean but also didn't resolve the problem.
  • Hello jimctr,

    Can you provide additional details on the environment? We're specifically looking for information such as:
    * Your system version (preferably including patch/SP number, i.e. Windows 10 x64 1709).
    * Other toolchains installed (GCC versions).
    * Which e2studio version does the problem occur with? Is it project/workspace specific?
    * When did the problem start occurring?

  • In reply to Renesas Karol:

    Hi Karol:

    I recently moved over from a Win 7 machine, so I don't have a huge amount of clutter.

    I am using Windows 10 x64 1703

    Other compilers existing on this machine:
    Atmel Studio 7.0 (most recently installed)
    Keil MicroVision 5
    Cypress Psoc Creator 4.1/3.3

    Currently using e2Studio 5_4_0_018 but this was also occurring with 5_4_0_023

    I have been having a lot of issues with e2studio ever since I moved to this Win10 machine, but this particular issue only cropped up a few days ago. Sorry to say I don't know the exact circumstances under which it appeared, but I was getting a compile error I didn't expect, and tried to force a clean and realized I was not able to clean. Was told that deleting the debug folder is equivalent to a clean, but this does not give me the warm and fuzzies.

    Kindly Regards,
  • In reply to jimctr:

    I have the exact same problem that just started out of the blue two days ago. I am still trying to figure out a way around it. If anyone has info, that would be great! This is BS...........
  • In reply to Gary:

    I am also using 5_4_0_023
  • In reply to Gary:

    WOW! I did some brief searching external to Renesas and notices the problem on W10 machines. One hint was to completely power down and then power back up. Doing so fixed the problem for me! I have NO idea why, but I did want to pass the hint along.