USBX HOST CDC-ACM sample program

Hi, Any one please guide me for USBX host cdc-acm program. i am new to renesas. please help me

  • In reply to Mariya K:

    Hi Mariya, I have tried the program that you shared in the link. But, In my case, I need USBX HOST CDC-ACM. In your program, that is USB DEVICE.
  • In reply to Praba:

    Oh, no problem, thanks for response. Some one from Renesas may respond to your question. You can also try by downloading sample projects from Renesas Gallary and this search on this forum.

    Mariya
  • In reply to Mariya K:

    Hi Praba,

    I have prepared two demo projects using SK-S7G2 (host) and PK-S5D9 (device) boards. Please find these projects below:

    S7_SK_USBX_Host_CDC_ACM_1_2_1.zip
    S5_PK_USBX_Device_CDC_ACM_1_2_1.zip


    Regards,
    adboc

  • In reply to adboc:

    thanx for the project....

    I've got this sort of running on my board. The thing appears to enumerate in the device manager (win10) as USB Serial Device (COM19) but no program I have actually sees (teraterm or HTerm)... doesn't show up on their list of devices.

    Eventually, the icon in device manager changes with an exclamation point. Properties shows:

    This device cannot start. (Code 10)

    {Device Timeout}
    The specified I/O operation on %hs was not completed before the time-out period expired.

    The driver is microsoft provided version 10.0.15063.997

    Any hints as to what I might look at here?

    thanx
  • In reply to rjl:

    Hi rjl-
    Read over this KB post to see if it addresses your issue:
    en-support.renesas.com/.../16977659

    Warren
  • In reply to WarrenM:

    I think it probably would if I could figure out where this file goes... This project in this thread (and mine) are SSP 1.2.1 and that runs a comm_v2 thing. I see nowhere that it's instantiated like the file in the pointed to explanation.

    searches of source don't show anything like this structure either.
  • In reply to rjl:

    Hi RJL-
    Yes the projects in the above posts are about a year old. Have you considered moving to a newer version of SSP?

    There are several application projects related to USB available here that might be more useful in a more recent SSP environment:
    www.renesas.com/.../keyword-search.html
  • In reply to WarrenM:

    RJL,

    If you are using a version of SSP earlier than SSP 1.5 then you need to change the device class code to Miscellaneous in the properties of the USBX Device Configuration. This is a known issue with the enumeration process for CDC-ACM class with Win 10 and was fixed in SSP 1.5

    -Gary
  • In reply to garyj:

    I did an update here to 1.5 (and E2 6.2.1).. That was painful.  Still no joy so I created a new project using the instuctions (exactly) of r11an0171eu0100-synergy-usbx-device-class-cdc-acm-mod-guide.pdf on my board using the blinky threadx as the basis (and commenting out the code that actually blinked).  I don't know exactly what version this app note was written for but I'm guessing not 1.5

    What I get doing this is showing:

    If I point to the .inf that comes with that project (as noted in the app note, page 12, it doesn't take it on my win 10 system here (just asks to look further afield).

  • In reply to rjl:

    changing the class code to Communications (CDC) doesn't change this.

    Looks to be getting "Matching Device Id: USB\DEVICE_DESCRIPTOR_FAILURE" and has the VID and PID set at 0 and 2 it looks like (I suppose it would if it's not getting the device descriptors). so maybe there's some other interesting problem here....
  • In reply to rjl:

    Back in my other project, I discovered that the function:
    VOID ux_cdc_device0_instance_activate(VOID * cdc_instance)
    {
    /* Save the CDC instance. */
    g_cdc = (UX_SLAVE_CLASS_CDC_ACM *)cdc_instance;
    tx_event_flags_set(&g_cdcacm_activate_event_flags0, CDCACM_FLAG, TX_OR);
    }

    is being called before the port enumerates completely. So if the thread hangs up prior to this, the OS doesn't figure out what's going on with the port. I can fix this by waiting 20 seconds but that's hardly a good thing to do.

    How do you tell when the port is actually fully connected then?