Upgraded to e² Studio 2021-04 from 7.5.1 - Debug Problem


I recently upgraded from e²-Studio 7.5.1 to the 2021-04 version and I am having trouble debugging my project. Usually I could select my launch configuration and just click the debug button but that doesn't work anymore. Clicking on the debug button ("Launch in Debug mode") doesn't have any effect and the settings button next to the launch configuration gives me the following error:

I am using a custom Synergy S7 board and with the old e² studio everything worked.

Is there anything else needed to get my program to run with the new version?

The only way I can start a debugging session is by right-clicking on the project and selecting Debug as> then selecting my debug configuration. However then I run into the problem that the debugging is slow. Like 2s for a single step slow. That was definitely faster before.

Please advise what to do in this situation.

Kind Regards,


  • Hello, cbismark.

    Check for your debug configuration referring the following FAQ page:
    Debugger configurations are not imported with project

    Debug toolbar button will work after once press Debug button in Debug Configurations dialog.
    (Note: Multiple debug buttons are seen in toolbar and each of them behave differently.)

  • Okra,

    thanks for your answer. That hasn't solved my problem however, even copying the launch files didn't help. I can specify the error: I can see the debug configurations, but there is another drop-down field that wasn't there before, named 'on:'.

    Since I can't choose anything from this field and also can't add anything to select there, the error from my first post probably stems from that. This field doesn't exist when I create a new blinky project with the new e2-Studio. And I don't have these problems there either. Has something changed in the way e2-Studio handles the projects?

    Creating a new project and importing all my config and threads into it has somehow solved that problem. But this is not really a workaround for anyone with more than 3 projects.

    The slow debug-stepping problem still persists.

    Kind Regards,


  • > Since I can't choose anything from this field and also can't add anything

    The LaunchBar (toolbar in up-left corner) recognize launch configuration (*.launch file) attached to one of the opened project. I don't recommend to use LaunchBar when you have troubles.

    You could launch debugger by using context menu of "Debug As" on *.elf file (instead of over project name).

    Debugger performance possibly be improved with disable rdimon spec in linker option, but not sure.

  • When I use a newly generated *.launch file (from e.g. an empty blinky project, created with the newest e2-Studio) and change all the paths inside the file to my launch target, it seems to works. This isn't too much effort, so as a workaround it is acceptable. Should be included in some changelog or doc anyway for people with the same problem like me.

    Regarding the performance, simply removing the --specs=rdimon.specs from the linker miscallaneous part of the build settings didn't help. Is there anything else to achieve this?

    EDIT: I set Run Break Time Measurement and Count every Core Cycle to 'No', now the debugging is as fast as before. But this was always enabled, how can this suddenly have an impact?