Conflict between NetX Duo BSD Support and USBX, FileX ?


I am using NetX Duo BSD Support to do Modbus TCP/IP.

In this project I also need USBX, (Host Mass Storage) and FileX.

Apparently NetX Duo BSD Support requires sources to work.
Therefore, I therefore have to put them also for USBX and FileX ...
For the configuration of the project no problem.
However if I compile I have a fatal error:

How to add this file to the project, or is it possible to run NetX Duo BSD Support without the sources. (Apparently not because if I delete them on the configuration, I get errors :

I put a "Development & Production" license, and I am in SSP v1.7.8

Thank you in advance for your help.


  • I tried to do a clean build of the project ...

    I also deleted the Synergy, synergy_cfg, and Debug directories.

    I regenerated the project configuration and recompile ...

    The error persists!

    However the source file does exist in the searched location:

    If anyone could help me ?...



  • In reply to Eric:

    Hello Eric!

    Have you tried re-installing the SSP? I do hope that our synergy experts will be able to help you out on this. Thank you for your patience.

    Best regards,
    RenesasRulz Forum Moderator
  • In reply to Sai:

    Hi Sai,

    No I don't try to re-instaling SSP...
    Is it really necessary?

  • In reply to Eric:

    To re-instll a SSP you need to do the following:

    Under your installation directory (examples)
    => C:\Renesas\e2_studio\internal\projectgen\arm\packs
    Delete the file: supportfilepacks.xml

    => C:\Renesas\e2_studio\internal\projectgen\arm\modules
    Delete the file: installedpacks.xml

    => C:\Renesas\e2_studio\internal\projectgen\arm
    Delete directorys that are based on the base SSP version(s)
    (example) 1.6 , 1.7 etc.

    The use the SSP installer and re-install the SSP version(s) you want.

    After that re-launch e2 studio.


    If you are still having issues then submit a ticket to the support team:

  • In reply to Michael Quirk:

    Hi michael,

    Thank you for your procedure.
    But I admit that I'm afraid of having to do that ...
    I already have projects running on the SSP1.7.8.

    The one I'm on, inherits from a working project to which I changed the S3A7 to S7G2 to add Ethernet.
    This project was working fine on S7G2 before I added the NetX Duo BSD support module, forcing me to add the sources on FileX and USBX (Host Mass Storage), causing the above compilation error. (Unjustified since the project generator added the source files ...)
    I will add that I am on a computer equipped with Windows 10 Pro, and that the e2studio v7.3.0 SSP1.6.3 version coexists in another directory (for other projects).

    Best regards,
  • In reply to Eric:


    I think I solved my compilation problem.
    In fact I had added the sources for USBX and FileX together.
    However, it would seem that it was enough to add them on the USBX part:

    Now everything is compiling, but I haven't been able to do the tests to verify that the USB and Modbus TCP / IP are working yet.

    Can you confirm that this is the right approach?
    (I didn't need to reinstall SSP).