Related to Ethernet

I used ssp 1.6.0 in my custom board.I used KSZ8091MLX ic for Ethernet connection.

Netx telnet server reference program properly work on DK S7G2 board.

But In DK S7G2 board when i give power supply then Ethernet connector LED was not ON.

In my custom board when i give Power supply then LED was ON.I am not run Ethernet program.

So how can i solve this problem please help me.

 

I have second question.

In my custom board i used KSZ8091MLX IC so it will run with Netx telnet server program?I have require to do change in program?

  • Hi sonu,

    Next time, please post Synergy related issues to the Synergy forum. I will move this post to the Synergy group. Also, regarding your first problem, please provide more info to help others identify faster the issue. Info like schematic diagram or how you connect the devices or boards. Thank you.

    JB
    RenesasRulz Forum Moderator

    https://renesasrulz.com/
    https://academy.renesas.com/
    https://en-us.knowledgebase.renesas.com/

  • In reply to JB:

    Hi Sonu-
    This post may help you find the code you may need to modify for your own Ethernet PHY.
    renesasrulz.com/.../using-ethernet-in-custom-board

    As to the lED issue, as JB says, we need some additional info to guide you. Tell us as much as you can about what isn't working for you.
  • In reply to WarrenM:

    Hi JB thank you for your reply,

     

    I give you my custom board Ethernet schematic.Please check and if i made any mistake then please suggest me.Because when i give power supply then my D12 and D13 no led ON.when i used DK Board then this thinks not happen when give power supply.

     

  • In reply to sonu:

    Hi WarrenM,

    Till now I am not able to solve this problem,Please give me some instruction so can able to solve this problem.
  • In reply to sonu:

    Hi Sonu-
    It looks to me like LEDs 11 and 12 on the DK-S7G2 board are driven by the Ethernet Enable signals. These seem to be different on your board. Am I missing something?
  • In reply to WarrenM:

    Hi WarrenM,Thank you for your reply.

    yes, LEDs 11 and 12 on the DK-S7G2 board are driven by the Ethernet Enable signals.But in DK S7G2 board when i ON Ethernet Enable Pin then LED was not ON.I observe in DK S7G2 board Only when program work properly then led will be ON other wise LED OFF.

    This think can effect on Ethernet functional?