IWDT S7G2 + iar + SSP1.5.2


I need your help.

I used thread monitor with WDT : working fine.

Now i wanted to move to IWDT : BIG ISSUE there is no reset, it seems that the timer doesn't work.



With WDT 


The mcu reset -> working


With IWDT 


The mcu DOES NOT reset-> PLEASE HELP


I tried for a day without success


Thanks for your help

  • The IWDT is controlled via the OFS registers, these need to be set to enabled the IWDT.



    The OFS registers are in FLASH, and the configuration is set in the BSP tab of  the SSC :-


  • In reply to Jeremy:

    Thanks Jeremy

    But i have already done, same issue
  • In reply to Ajith:

    What settings are you making in the OFS registers, and are you using ThreadX?
  • In reply to Jeremy:

    yes i am using threadx.

  • In reply to Ajith:

    The attached project works for me, the iWDT generates a reset (with the iWDT settings you have used above) :-



  • In reply to Jeremy:

    Jeremy thanks for your support,

    I tried it doesn't work for me.
    1) there are several error on compiling, in the configurator there is no iwdt

    I manage to fix it -> iwdt does not work

    2) i replace iwdt by wdt --> it works
  • In reply to Ajith:

    When you say :-
    "2) i replace iwdt by wdt --> it work"

    What exactly do you mean? Does the iWDT trigger a reset, or does the WDT trigger a reset?

    What is the clock setup in your system, what is PCLKB in your clock configuration?
  • In reply to Jeremy:

    Hi Jeremy,

    I think by "2) i replace iwdt by wdt --> it work", it means that the reboot is successful with wdt but not with iwdt.
    I have the same problem on SSP 1.4.0,
    I can use the wdt to generate an interrupt or a reboot without problem, but when I try to use the iwdt component, this just dont do anything.

    And as Ajith said, your project seems to be missing the iwdt object in the Threads tab so we had to add it in order to make the whole project compile.

    I hope you can help us :)

    Have a nice day,

  • In reply to Clément:

    Hi Clément,

    You had the same issue as me

    Clément, do you work for a french company ?
  • In reply to Clément:

    Here is the project again, with the configuration fixed.


  • In reply to Jeremy:

    Thank you Jeremy,

    Unfortunately, when I transform your code to work on the custom board I'm working with, nothing change...
    I use a R7FS5D97C µC on my board but the code should work exactly the same no ?

    I hope we can solve this :)
  • In reply to Clément:

    It works on an S5D9-PK for me. I changed the board to S5D9-PK, and made sure the iWDT Start mode is "IWDT is automatically activated after a reset (Autostart mode)" in the OFS register settings :-



    and after about 20 seconds the code stops at the same point as before.

  • In reply to Jeremy:


    Thanks Jeremy for your help

    There is an issue with S7G2 it doesn't work, i already told you.

    There is an issue on framework or silicium issue.

    Warren can you plz check with Renesas
  • In reply to Ajith:


    Which board are you using?
  • In reply to Jeremy:


    I am working on our custom board.
    Clément has the same issue on a custom board.