SD Card 4bit problem

Hi,
I have got an issue with SD Card, it is working in 1bit mode, but stops within the 4 bit mode. (FX_IO_ERROR)
i checked the physical connection and its ok. Down there is my configuration. I am using Embedded mode because with Card mode it doesnt working at all.
My board: TB-S5D5. 

 

  • Hi KG,

    Could you check if SDHI1 pins are properly configured (Pins tab > Peripherals > Storage:SDHI > SDHI1)?

    Regards,
    adboc
  • In reply to adboc:

    Every DAT pin has got configuration as this shown on picture

  • In reply to KG:

    Hi KG,

    The configurations seems to be correct. Are you sure the card is properly connected to these pins?

    Regards,
    adboc
  • In reply to adboc:

    I have checked that once again. It is correct.
  • In reply to KG:

    Hi KG,

    Which SSP version are you using? Which FileX function does return FX_IO_ERROR? One of the call to lower level API must fail, could you check which one? You may look into sf_el_fx.c file (synergy/ssp/src/framework/sf_el_fx), there is the FileX driver on Block Media, it fails with FX_IO_ERROR if any of the lower level API returns an error code different than SSP_SUCCESS.

    Regards,
    adboc
  • In reply to adboc:

    SSP 1.5.0
    Now, fx_media_open returns FX_BOOT_ERROR, (in fx_media_init0).
    In lower level I got SSP_SUCCESS
    Then in logs:
    Cannot get available space
    Creating directory
    Error occurred, code: 11
  • In reply to KG:

    Hi, I have same issue. We have made SDcard connection on PE-HMI1 customized board. we referred DK-S7G2 development schematic.

    What is the maximum size for SDCard can be used in S7G2?
    can S7G2 support microSDCard with this same configuration?
  • In reply to Prabakaran:

    Hi.
    I use 128GB microSD with S7G2 without problems.

    Paolo