DK-S7G2M out of the box demo fails

I just bought a DK-S7G2M v3.1. I followed the quick start guide and the Out of the box demo fails. Basically Led3 = green, led1, led2 =Red, the rest a dim Red. Ethernet leds never lit, no splash screen. Tried a different usb cable, all usb ports on PC, and a different PC.

  • Hello WMK,

    to be able to run the Out-of-Box demo all three boards have to be correctly connected - as shown in the image on page 1 in the DK-S7G2 Quick Start Guide (r12qs0001eu0101-synergy-dk-s7g2.pdf). This is probably the same document to which you referred to. I noticed a mistake in the above document - to run the demo it is necessary to switch the S5:1 DIP switch (DRAM) to the "ON" position. The switch is placed on the DK-S7G2M board. For the most recent demo and correct documentation please refer to the Getting Started with Thermostat Application for S7G2 and S5D9 - Application Project, which contains the demo (DK-S7G2_Out_of_Box_Demo.zip) and the DK-S7G2 v3.0 Out-of-Box Demonstration Programming Guidelines (r12an0024eu0127-synergy-dk-s7g2-oob-program-guide.pdf).

    Best regards,
    anper

  • In reply to anper:

    anper:
    I thank you for your aid, but the result was the same. Just to be sure I have both JTAG and DRAM on. I also tried all combinations between the two switches with the same result. I tried the second link, but when I did the download, it was page not found. I'll continue looking. I'm wondering if it is J-Link as even though it says it is operating normally, it indicates in events of a migration issue that seems to USB 3 (I Have) versus USB 2 which seems to be wanted. Any commentary on that is also welcomed.
    Thank you for your time,
    WMK
  • In reply to WMK:

    Hello WMK,

    today I also had difficulty connecting to the second link, however now it seems to be working fine. Please try again. Hopefully, downloading the new demo and following the instructions provided in the accompanying document will solve the issue.

    Best regards,
    anper