JCU Glitch issue

Hi all,

I am using RZ/A2M - JCU to encode the image to JPEG.

I was facing glitches in the frames while continuously encoding the YCbCr 422 frames from the camera to JPEG image using JCU unit.

Is JCU unit has support for continuous encoding feature from the camera or it has any limitations regarding this.

Kindly reply as soon as possible.

Thanks.

 

Bad image with glitches :            Good image :
  

Parents
  • The JCU supports 132MBytes/sec processing (encode/decode). Have you checked the input image coming from the camera when a glitch occurs?

  • Hi michael kosinski ,

    I think there was no issues regarding input frame.

    I have attached the image(320*480) when the glitch occurred below, Here you can see at the bottom the last perfect row of data was repeated till the end .

    that is from row 380 to 480 were the same data that was in the 380th row.

    Glitch happens in the following pattern while streaming.This happens only at the bottom.

    If possible kindly send any sources that is related to JPEG encoding while streaming at 30fps for any resolution.

    Because, in sample application package, only single frame is encoded and decoded.

      

Reply
  • Hi michael kosinski ,

    I think there was no issues regarding input frame.

    I have attached the image(320*480) when the glitch occurred below, Here you can see at the bottom the last perfect row of data was repeated till the end .

    that is from row 380 to 480 were the same data that was in the 380th row.

    Glitch happens in the following pattern while streaming.This happens only at the bottom.

    If possible kindly send any sources that is related to JPEG encoding while streaming at 30fps for any resolution.

    Because, in sample application package, only single frame is encoded and decoded.

      

Children