MIPI Aistarvision Mezzannine Adapter board v2.4 and RZG2 interface with OV5645

Hi Team,

I am trying to Connect Ov5645 MIPI CSI2 camera using Mezannine adapter v2.4  with RZG2M  Hihope v4.0 board.

After power on i dont see any video or media instances being generated for MIPI camera.

Can i please get the hardware and software configuration for succesfully interfacing the CSI2 camera with RZG2M. Also this is to inform that am working on yocto bsp.

thanks and regards.

Parents Reply Children
  • Hi Sai,

    Sorry, I think last reply didn't get updated properly.
    I have already read the document but provided, but could not find any procedure to interface mipi camera.
    Also I have tried updating the Device tree file.

    I2C2 adapter detects the camera on 0x3c address but I could not stream through the command:

    gst-launch-1.0 -e v4l2src device=/dev/video13 ! video/x-raw,format=YUY2 ,width=640,height=480,format=UYVY ! waylandsink position-x=50 position-y=50 &

    And even I can see that i2c5 adapter(second camera connected to i2c5) doesnt detect the camera slave on the bus. When checked through

    i2cdetect -y -r 5

    Please provide the solution for connecting MIPI camera with Aistarvision Mezannine MIPI adapter.

    Thanks and Regards

  • Do, anyone has any solution regarding this

  • Normally in the default rootfs (/home/root/) you should find a script (vin_init.sh) that should assist you in performing the needed configurations.

    You can find the documentation in the RZ/G2 Group BSP Manual Set, more in particular in VideoCapture document, especially section 5.2: Media Controller API.

  • Hi MicBus
    As per renesas build documentation vin_init.sh is configured as per the criteria for mipi camera. But then to kernel is unable to find and execute the camera command.

    Thank you for the manual Micbus. I will go through the document once and check.

  • Hi Shailendra, 

    Were you able to find an answer from the document given by MicBis? 

    RenesasRulz Forum Moderator


  • Hi Herald,

    I have gone through the documents of gstreamer and video capture and tried to stream mipi camera throught the procedure given in the document. I have tried performing the command on all video instance generated after pluging the camera adapter.

    But i can only see the errornous pipeline message responding to all of them.

    I can seen through media-ctl command that entity is being created for ov5645 camera but streaming or video capture the procedure doesnt workout.

    Also i have'nt got the solution for the second camera instance. As i cannot see any device interface with i2c5.

    Please provide solution for interfacing Aistarvision mipi camera adapter v2.4 with hihoperun rzg2m v4.0 board.

    Thanks and Regards

    Shailendra Vikram Singh

  • Once the video device has been created using media-ctl, try this pipeline:

    gst-launch-1.0 -v v4l2src device=/dev/video1 ! 'video/x-raw,format=UYVY,width=1280,height=960,framerate=30/1' ! vspmfilter dmabuf-use=true ! 'video/x-raw,format=BGRA' ! waylandsink

    You would need to adjust video device and resolution.

  • Thankyou Micbus for the command.

    We were able to interface first Mipi camera with RGZG2M board.

    Now, the second camera , is not getting detected as any I2C instance. How to resolve this.

    We have updated the dts file and adapter is getting shown up, but camera detection isnt't happening.

    Will be gratefull if you, Please guide for the issue.

  • What is the HW configuration of your MIPI mezzanine board? How did you configure J13 and J15?

    Note that the correspondance between mezzanine and RZ/G2 is respectively:

    I2C0 = I2C0 (low speed connector)

    I2C1 = I2C3 (low speed connector)

    I2C2 = I2C2 (high speed connector)

    I2C3 = I2C5 (high speed connector)

  • Please find the Connection of the J13 ,J14 and J15 connection in the Pic.

    Clock connection of J14 is 1-2 and 7-8

    this is the same connection i am trying to impelment both the cameras, of which 1st one with i2c2 got working. I have tried updating the i2c3 instead of i2c5, but then too i am facing similar problem. Cannot see any i2c slave on i2c3.