FIT module r_tfat_rx 3.03, r_tfat_lib function R_tfat_f_utime fails

Hi everyone!

I tried out the USB Host MSC sample application that writes a demo file "hmscdemo.txt" to USB stick. Everything works so far but when I try to change the files date and time stamp info (R_tfat_f_utime) it fails if the files extension is not exactly "txt". In that case date is always 23.02.2009 and time is always 14:02. With txt extension everything works fine, but if I change the file extension the function fails. Has everyone else tried out  that? Has anyone an idea or a solution?

Kind regards, Ralf

  • Hi Ralf,

    Have you already found the solution? Let's wait a little bit more until someone who have tried this one can help you with your issue. Thanks for the patience.

    RenesasRulz Forum Moderator
  • Hi everyone!
    The situation was frustrating but I kept on struggeling. I found the solution by myself :-).
    I saw a problem that was not really a problem at all. I wrote a file to USB disk with our application. Then I changed the timestamp (R_tfat_f_utime) and wondered when I checked the file in my windows computer. Windows shows the initial timestamp only (23.02.2009). I didn't recognize that the columns of the file explorer were not configured correctly. I only had to insert the modification date and everything was fine.

    So, all you guys at RENESAS did a graet job with M3S-TFAT-Tiny and also JPEG-Encoder. FIT is also a very helpful an time saving system!!!

    Now I am back into business, application works fine, everything is fine :-)

    Best regards from Germany, Ralf
  • In reply to JB:

    Hi JB,

    thank you for taking care!

    The solution was found by myself. Ihave been tricked out by myself. I put my own answer to my question if anybody has a similar problem in the future.

    Kind regards, Ralf
  • In reply to Ralf Sinzig:

    Hi Ralf,

    First of all, it was great to know that you have already found the solution to your issue. I'm sorry if the forum was not able to help you with the issue. Also, thanks for sharing your solution. This would really help other members in the future who would face the same issue. Good luck with your project. Have a nice day!

    RenesasRulz Forum Moderator
  • Hello Ralf, JB,

    I still see the same issue as described by Ralf. Strangely I see this issue with TXT files as well. Please see the attached screenshot. To confirm the timestamp is proper I checked on Linux system, where the date is shown as 23.02.2009.

    Can you please suggest if I have missed something?