Error in Migration from IAR to E2studio

Dear Sir,

            Earlier I was using IAR Embedded Workbench for RL78 1.10 for my Renesas R5F100jea Project.

 As due to some problem i had change  system from Windows 7 to Windows 10.Now the IAR Embedded Workbench for RL78 1.10 is not getting installed on windows1o therefore I have installed E2studio7.5.0.

           I have imported the Earlier IAR project  into E2studio.Now on Building the Project I am getting the following  Error:

Extracting support files...
[ERROR] No toolchain set or toolchain not integrated.
11:13:31 **** Build of configuration Debug for project firz11 ****
make all
Cannot run program "make": Launching failed

Error: Program "make" not found in PATH
PATH=[C:/Renesas/e2_studio/eclipse//features/com.renesas.jre.win32.win32.x86_1.8.0.181/jre/bin/client;C:/Renesas/e2_studio/eclipse//features/com.renesas.jre.win32.win32.x86_1.8.0.181/jre/bin;C:/Renesas/e2_studio/eclipse//features/com.renesas.jre.win32.win32.x86_1.8.0.181/jre/lib/i386;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Renesas\e2_studio\eclipse]

11:13:31 Build Failed. 1 errors, 0 warnings.

Do any more Toolchain need to ne installed along with,kindly please re vert back on this ??

  • 1. I don't understand why EWRL78 V.1.10 should not install on Windows 10. I installed it on Windows 10 and it seems to work fine.
    2. What do you mean by "... imported project to e2 studio..."? Even if you open the IAR project in e2 studio, e2 studio still requires the IAR compiler to compile the project. If the IAR compiler is not installed it does not work.
    You could consider to move the project to CC-RL compiler. But this requires some re-writing of the code (different pragma instructions, different intrinsic functions, ...).
  • In reply to FrankL:

    Dear Sir,
    Can you provide any link for EWRL78 V.1.10 SETUP for windows 10.Because the one setup i have is not working.
  • In reply to Fizz:

    EWRL78 V.1.10 is old. If you have a licensed version you can ask IAR support if they can provide an installer.
  • In reply to Fizz:

    Fizz,

    Have you resolved your issue?

    Mike Clements
    RenesasRulz Moderator