PicoFDL (T04) with IAR RL78 2.xx


MCU: RL78/G13

We are now migrating from IAR 1.xx to 2.xx due to other issues and our dataflash library doesn´t compile with the new version because the tool provided by Renesas "RENESAS_FDL_RL78_T04E_V1.20" only allows generating libraries for 1.20 version of IAR.

Should we expect Renesas to update this tool for new versions soon? Or is it better to switch to other flash emulation library (T01 e.g.) assuming the cost in code size? Any alternative?

Thanks in advance!

  • In reply to ThomasDamgaard:


    try  Progect->Contecst Menu->ReBuld All

    may be anyDesc or Team Viewer or Alpemix ...

    check the power, maybe a problem in it ...

  • In reply to andrvisht:

    Rebuilding doesn't help. I also tried using IAR 2.2 but still the same.
    My power supply can deliver 3A so that should be fine.

    Thanks for the help! :)
  • FDL_RL78_Type04_Installer_V200 supported IAR 4.10.1
  • In reply to andrvisht:

    It resets when I step to the next line:

  • In reply to ThomasDamgaard:

    This is extremely incomprehensible.
    Because your project, in which I changed only the frequency source and deleted from the project * .a, it behaves normally with my E1 debugger.
    I mean the food on the board itself, and not what you feed it.
    Try to debug the FDL function to see where the problem is. I assure you that the call agreement has not changed since IAR 2.1.
  • In reply to ThomasDamgaard:

    You must disable your WatchDog Timer or use R_WDT_Restart () in your loop.
  • In reply to andrvisht:

    I've made a new project with only the data flash enabled.


    Now it breaks here after continue run from R_FDL_Open():

  • In reply to ThomasDamgaard: