PicoFDL (T04) with IAR RL78 2.xx


MCU: RL78/G13

We are now migrating from IAR 1.xx to 2.xx due to other issues and our dataflash library doesn´t compile with the new version because the tool provided by Renesas "RENESAS_FDL_RL78_T04E_V1.20" only allows generating libraries for 1.20 version of IAR.

Should we expect Renesas to update this tool for new versions soon? Or is it better to switch to other flash emulation library (T01 e.g.) assuming the cost in code size? Any alternative?

Thanks in advance!

  • You can download the updated FDL libraries for the IAR v2.x tools from our website.


  • In reply to Calvin Grier:

    I can't find the library in this link, no library for IAR there (see below what I find in the link). I wonder if the website is not correctly working.

    I received a zip file  "RENESAS_FDL_RL78_T04E_IARV2_V1.00" from our Renesas contact, that is exactly what I was looking for, so the problem is solved.

    Thanks for the reply anyway.

  • In reply to txen:

    The mentioned library is in the "European downloads / MyPages" section in the website, it is not reached with a regular website search.

  • can you send me the file ,I need it, "RENESAS_FDL_RL78_T04E_IARV2_V1.00",My email 905627478@qq.com ,Thank you very much
  • In reply to WO ARO:

    You can find the file in this link:


    Select RL78 and SW-Tool in the filter and you will see it under "EEPROM_EMULATION_RL78" product name.

  • In reply to txen:

    Too I look for RENESAS_FDL_RL78_T04E_IARV2_V1.00.zip library
    But according to the reference there is no support for IAR 2.x
    Also on the website Renesas I have not found it too.
    If you still have it, ask to send it to me andrvisht@gmail.com
  • In reply to andrvisht:

    The files are still available on MyPages as txen wrote.
  • In reply to FrankL:

    Correct, they are available on Mypages. For all who may be interested: versions for IAR compiler are only available if "America/Europe/Middle East/Africa" is selected in the beginning of the installation.
  • In reply to txen:

    Yes, thanks.
    I have already understood it:)
    too is suitable for IAR 4.10.1.
  • In reply to andrvisht:

    I've downloaded the FDL_RL78_Type04_Installer_V200.zip file and made a simple project using Applilet3 for IAR 4.10, but when PFDL_Open() is execute I get the error:

    Fri Jul 05, 2019 10:04:02: Unable to execute: driver error. After the error occurred, the program counter (PC) was 0xefff8.

    I'm using a QB-R5F100LE-TB board.
  • In reply to ThomasDamgaard:

    Perhaps you have not opened access to Data Flash
    DFLEN = 1U;
    for (w_count = 0U; w_count < 6U; w_count++)
    or not linking libraries.
    I tried the old FDL for IAR 2.x with version 4.10.1 and everything worked.
    Give me an email and I will send it to you.
    And if these files are available for you to download, it would help me.

    As for the problem I described with Type 01, I solved it. As it turned out, due to the fact that I had data previously recorded using the DFlash library, the formatting command produced an error. As soon as I erased them, everything began to work.
    my email: andrvisht@gmail.com
    Best Regards.
  • In reply to andrvisht:

    Hi andrvisht,

    Thanks for responding!

    The code generated by Applilet3 takes care of enabling the data flash:

    /* Start data flash control */
    DFLEN = 1U;
    for (w_count = 0U; w_count < 13U; w_count++)
    /* End data flash control */

    And I have added the library in the linker setup.

    I had the debugger set to Simulater. I've changed it to E1 and now it resets after the call to PFDL_Open().

    I have a breakpoint in R_Systeminit() and a breakpoint in the line after PFDL_Open(). After the call to PFDL_Open() the R_Systeminit() breakpoint is triggered.

    I've attached my project.


    BR, Thomas


  • In reply to ThomasDamgaard:

    I think your problem is that you have attached the library to the project files.
    Remove *.a it from there. To connect libraries of the * .a type, you need to use the Oprions / Linker / Library options in the project settings. And there you have it also connected.
    I changed your project for my R5F1006C and reconfigured it to an internal generator. Check it out, it works for me.

    I can not understand where to add the file of the modified project, so I described my actions.

    If you can help with the download on my links, I will be grateful.
  • In reply to andrvisht:

    I've removed the library file, but it still resets. And also tried with the internal generator but still the same... Strange! :(


    You can attach files by clicking "Use rich formatting" then Insert->Insert image/video/file or just drag&drop the file into the editor.