Renesas RA6M4 E2 Studio Debug and Programming Problem


I designed my own hardware using R7FA6M4AF3CFP and Lattice FPGA and did not use QSPI external flash. But no matter what I do to this hardware I can't assign a program. I wrote a simple code to turn the LED on and off, I wrote a blank code, I tried to program the sample project (quick start) from the EK-RA6M4 sample project package, but I can't program in any way.

Using SEGGER J-Link v7.52, I disabled bank 4 (QSPI bank) and deleted the flash banks of the chip. Then I tried to program the hex file of any project using J-Flash. It threw the program, but it gave the following error at the verify stage.

 - ERROR: Verification failed @ address 0x0100A130 (CRC: 0x9E98F5B4, Expected: 0x2902BB0B)

When I try to switch to debug mode using E2 Studio, I keep getting the same error;

GDB action 'Finished download', has failed with error report, failed to download
Hardware breakpoint set at address 0x35ab0
GDB action 'read memory', has failed with error code, 0xffffffff

When I try to switch to debug mode using IAR 9.20, I keep getting the same error;

" Warning: Stack pointer is setup to incorrect alignment. Stack addr = 0xffff'ffff "

When I create a Flat-Zone project, "Device Partition Manager" appears, and I don't know what to do on this screen.

" Establishing connection : FAILED! The emulator chosen is not supported. "

Can you help me?

Parents Reply Children
No Data