HEW hangs with FoUSB

I have been working on a project using a M16/Tiny 026F8.  To debug the project, I took a QSK26A and removed the 026F8 from the board.  I then added a 14 pin header to the board and to that header attached the needed lines to control an outboard 026F8.  Specifically:

Pin #   M37641F8HP    026F8

Pin 1    pin 29              pin 28 (P6-5)

Pin 2      gnd                      gnd

Pin 3    pin 59              pin 4 (CNVss)

Pin 4    n/c                   n/c

Pin 5   pin 28,56           pin 26 (P6-7)

Pin 6     gnd                        gnd

Pin 7   pin 57                pin 6 (P8-6)

Pin 8   Vcc                     Vcc

Pin 9  pin 61                  pin 29 (P6-4)

Pin 10  gnd                     gnd

Pin 11  pin 27                pin 27 (P6-6)

Pin 12  gnd                      gnd

Pin 13  pin 62                pin 7 (*reset)

I built a prototype PCB and had it working with HEW.  I had a production run of the PCB's done and they do not work.  I have checked for errors, but the boards ring out identical to the prototype PCB.

I can open up FoUSB and it says it downloads the program and verifys it - but the board does not work when power is applied away from the QSK26A.

In HEW, it recongnizes the board on startup for debugging, and also allows me to download a program. (It does pause for a few seconds after reaching 100% which seems strange)  When I start the program in HEW, nothing seems to happen - breakpoints do not work.  Clicking on the stop button gives the "Communication protocol error (Argument error)(16230)" and I have to use Task Manager to close HEW.

One difference I just thought of is that I am running WIn7 now where I was running Vista before.

If needed, I can post the schematic on my website.

I would really like to get these items on the market, so any help you can provide would be appreciated!



  • Hi David - notice that you have had 30 views in over 24 hours and no answers to your question - kind of sad.

    I thought I would update myself on the latest efforts to make the production boards work - I have an E8 so I loaded the software for it and tried running HEW and my program with the production board with the E8 to see if it would work. It does not - the E8 times out.

    I realize that using the QSK26 the way I did was not "standard" and why Renesas (if they read the forum) would not reply - thus the effort with the E8. But why bother using the QSK26 if you have an E8 available? Simply - the E8 does not provide all the functionality of the QSK26 debugger. As I recall a conversation with Renesas, you have to buy the E10 to have software breakpoints - yet the QSK26 provides software breakpoints with HEW!

    Working with Renesas products for the past 5 years has been a definite love/hate relationship. I love the products - I have used the 26A and 62P on a number of successful projects with the QSK boards. But trying to get the microcontrollers to talk to a debugger with custom hardware has proven to be almost impossible - once with a 26A and once with a 62P. The support received via the forum has been almost non-existent.  I realize I am not a major source of income for Renesas – but I feel that there should still be some sort of support for us small guys.

    I have been designing with and programming microprocessors longer than some of the staff of Renesas has probably been alive (35 years).  So it is not like I do not have a clue as to what I am doing.

    Perhaps the time has come for me to accept a $150 loss on the production boards and another $200 loss on 0260F8 and 62P processors and move on to a different platform

    Not looking for sympathy - or expecting a reply.

    A very frustrated David

  • I m probably not going to be much help but in regards to your win7 vs vista comment have you tried using windows xp mode? I have a lot more luck using that on older MCUs.

    I ll also ask a few renesas people if they have any idea on what might be going on.

  • I've noticed quite often that the combination of HEW/KD30/FoUSB can act like a download is occuring, but in fact one is unable to get the target CPU to boot when it's all finished. A tip-off is that the download looks different (really slow usually in my case). I've learned to abort at that point and restart everything.  Similarly you wrote "(It does pause for a few seconds after reaching 100% which seems strange)"

    Anyway, you wrote "One difference I just thought of is that I am running WIn7 now where I was running Vista before" which begs the question, have you tried the new boards with Vista (or XP)?

  • It looks like your hardware uses only port P86 on M16C/26A to switch the processor to flash programming mode.

    There is a technical news on the Renesas homepage warning about possible problems when doing so:


  • Your are correct Frank - but as I have stated, I am using a QSK26A board that has the 26A removed.  All the control signals from the M37641F8HP to the 26A are still going to the 26A, just not on the QSK26A.  I am at a failure to understand how the problem addressed in the technical article (which addresses several of the lines being used) does not manifest itself on the QSK26A board, but does it the 26A is offboard . . . . . . .

  • All of the on-chip debuggers require firmware on them to support the devices they connect to. The "FoUSB" on the QSK was never intended to act as a general purpose debugger - that's what the FoUSB boxes were for. (If you need some, I'll be happy to mail you a few - contact me via private message.) The FoUSB boxes supported all the M16C/26A devices, but the QSK supported only two chips as far as I know. (It is possible that a depopulated QSK could be used to connect to any 26A target, but that's really a hack of the QSK.)

    In any case, the QSK, FoUSB and the E8 are not well supported in Windows 7 (although I have heard they work under the Win 7 XPM). E8 should work fine running under Win XP, with all the features of the FoUSB. I think the 32 bit driver for E8 works on Vista-32. However, your best bet is to buy an E8A from Digikey or Avnet (or another distributor) to do debugging

    It is obvious you like the QSKs based on previous forum activity. But it also is also apparent that you have a lot of difficulties with this approach, based on the number of forum messages in the last couple of years. If your production boards have the 14 pin headers for the E8/E8A, I'd recommend using the E8A.

    (Don't forget that there are options using RS232 level shifted to TTL like the one from DJ Delorie, if you just want to download. http://people.redhat.com/~dj/m32c/)

  • I guess I was unaware of a FoUSB box.  Seems that is what I have been trying to create with the QSK board.  I knew that the QSK had limited cpus it would respond to - that was evident in the FoUSB loader.  So I have always tried to get the same chip that was in the QSK - yeah I screwed up one and got 48k rather than 64k chips.  I have a couple of E8s, but never an E8a model.  I will take a look at Deorie's website you referenced.



  • I recevied the RTA-FoUSB-MON on Friday - Thanks CKGRIER.  I had to make a cable for it since the pin configuration of my target board is different from the RTA-FoUSB-MON.  I powered it and and downloaded the file for the M30260F8A, since that is the processor on the target board.  I disconnected the RTA-FoUSB-MON from the PC, connected it to the target system, changed the power to target from USB, powered up the target and plugged in the USB cable to the RTA-FoUSB-MON.  Steady RED LED for power, blinking STATUS LED.  Fired up HEW, setup Debug session for M16C R8C FoUSB/UART as IEEE695_RENESAS and $(CONFIGDIR)\$(PROJECTNAME).x30   OFFSET 0   Format IEEE695_RENESAS.

    Under Debug, I chose CONNECT and bless be if it did not connect! The STOP LED comes on.   Downloaded the x30 file to the target CPU - a little delay after hitting 100%.  Click on RUN and the GREEN LED comes on, the STOP LED is off, the STATUS LED is blinking.  BUT none of the LEDs on the target board are blinking to indicate startup.  Click on the STOP button in HEW and I get "Communication protocol error. (Argument error) (16230)" and the system hangs.

    Crash HEW, unplug the USB cable, cycle target power, plug USB back in, fire up HEW.  Try single step.  First instruction runs, click single step again, "Communication protocol error. (Argument error) (16230)"

    I have posted a copy of my schematic and cable to the targe at http://www.dv-fansler.com/hidden.htm  It is a PDF file.



    Additional Info - looking at the crystal when the target board is stand alone, one side of the crystal is at 5v, the other side is at ground instead of a 10 MHz sine wave.  This could be a problem.  Question - when does the clock circuit become active?


  • Even more data - I put a new CPU on a new target board last night with only the 10MHz crystal, 15pF caps and two .1 bypass caps for the CPU.  Hooked up an oscilloscope to the crystal.  Powered on the circuit with 5v.    Xin was at abot 2v while Xout was a 1v sine wave at 10MHz riding at about 3v.  After about 5 seconds the sine wave went away and Xout dropped to ground.  Changed crystals and it remained the same.

  • Hey David,

    The only thing that I could think of that would cause the oscillator to fall off after 5 seconds is if the resonance of the oscillator and the capacitor circuit are not perfectly matched.  Have you tried varying capacitor values or tested them to ensure that they are within allowable variances according to manufacturer?


  • Hi Anothy - thanks for the suggestion - I am not sure why I had not thought of if before - I had run into that problem with MicroChip processors and had switched to using oscillators instead of crystals.  I tried a 10MHz oscialltor and the board came to life.  Unfortunetly the RTA_FoUSB still will not connect to the board.

    Thanks again,