Compact Emulator errors

Hi,

I am new to Renesas products. I have got a Compact Emulator M3062PT3-CPE with M3062PT-EPBM MCU board as my hardware setup. I am running HEW 4.09.00.007 using Renesas M16C Toolchain V6.0 and M16C R8C Compact Emulator Debuuger V1.03 Release 00.

I am able to CONNECT to the emulator and start running my project. However, on hitting a HALT button, it starts showing "Can't send data (16013)" error. The "self check" option when clicked on the emulator init dialog, it shows "target is used already (16015)".

The self check test when run from the emulator (After pressing the reset button twice as described in the manual), shows Power LEDs and Reset and SAFE LEDs ON. This condition is described in the manual as "Emulator may be damaged". But if the emulator is damaged, HEW is still connecting to the emulator, so I rule out this possibility.

Can anyone please give some clue how to debug this problem?

Thanks in advance to all.

Parents
  • I created another simple project of type "Application" from the project wizard. it created a main() function and I just put a couple of dummy lines code there. It works fine. I am able to debug source level, put breakpoints, view disassembly code etc. So there seems a problem with the other project which I was trying to debug. At least my emulator is working well.

Reply
  • I created another simple project of type "Application" from the project wizard. it created a main() function and I just put a couple of dummy lines code there. It works fine. I am able to debug source level, put breakpoints, view disassembly code etc. So there seems a problem with the other project which I was trying to debug. At least my emulator is working well.

Children
No Data