"Disassembly" file after downloading with R8C E8a Emulator Debugger

Hello,

Since this morning, I have the following problem: when I download my program with the R8C E8a emulator, a "Disassembly" file is opened in the editor window instead of the "ncrt0.a30" file. I can run the program, it seems working well, but I can't use breakpoints or other stuff like watch, register or IO windows.

It seems to me I loose the link between my C source and the program running in the µC.

That was working well last Friday and my versioning software (TortoiseSVN) doesn't find any differences.

It's the third time that happens. Could you help me to resolve this problem?

I would like not recreate my projet like for the two other times.

My system:

  • Win XP pro SP3

and directly from the HEW About window:

  • C/C++ Compiler Package for M16C Series and R8C Family V.6.00 Release 00    (8-8-2011 16:49:08)
  • C/C++ compiler package for the H8, H8S, and H8SX family V.7.00 Release 00    (8-16-2011 09:25:28)
  • H8S,H8 300 Simulator Debugger V.5.09.00    (8-18-2011 18:18:42)
  • E8a Emulator Software V.1.05 Release 00    (9-1-2011 10:23:01)
  • M16C Series, R8C Family C Compiler V.5.45 Release 01    (9-2-2011 08:57:33)
  • E8a Emulator Software V.1.00 Release 00A    (9-2-2011 09:07:10)
  • M16C Series, R8C Family C Compiler V.5.45 Release 01 (Update Utility)    (9-5-2011 10:50:39)
  • E8a Emulator Software V.1.05 Release 01    (11-8-2011 14:01:33)
  • High-performance Embedded Workshop Upgrade 4.09.01    (7-30-2012 10:59:04)

My µC : R5F21236.

Thanks.

  • Did you try to do a "Build All"?

    The disassembly window should allow the same breakpoints as the source window.

    What does it mean you cannot use register or IO window? Are the buttons or menue entries greyed out? In this case the windows are opened but out of view. On start HEW shoud claim that some windows are out of view and ask if it should reset the window position.

  • Thank you for your fast response.

    Yes, I did a "Build ALL" three or four times and I obtain the same result.

    More exactly, I can add breakpoints and use the register window, I can see the evolution of the values in the PC, R0, R1,... registers (I haven't try with IO window). But I have only one very long disassembly file in the editor. If I run my program step-by-step, I run each line of this file instead of the C functions as expected. It's like I'm running the result of the compilation in assembler without any link with my C code. So I don't know where I am in my program.

    Sorry, I don't know how to explain more clearly.

    The last week, when I was running my program, I was able to see in the éditor what C function was executed or what C variable was written or readed. I was able to place a breakpoint exactly wher I want in my C source. That was clear and easy.

    Today, I have just a big assembler file where the yellow arrow (the PC location) is moving instead of my friendly C files.

    I'm a little disappointed.

    Thanks.

  • In this case "only" the debug information in your debug file is missing.

    Do you load the absolute file (*.abs) selected as debug module?

    Please check your compiler options. Is the "-g" option still selected for the compiler?

    Is the "-N" option NOT selected for the assembler?

    Is the option "(-debug) In output load module" selected for the linker?

  • Yes I have loaded and reloaded the *.abs file and not better. I have the disassembly file in the editor.

    About the compiler option, the "-g" option wasn't selected, so I did it. The others were unselected for the assembler and selected for the linker.

    I rebuild all and download again and... disassembly file.

    Something I notice: if I click on the icon to view the C source of the disassembly file, it ask me to give the corresponding file.

    Thank for your help.

  • If HEW asks for the source file this means it has the debug infromation but does not find the file.

    Does your build all work without errors and warnings?

    Do you have some language specific characters in the path name which could confuse the compiler?

  • When I build all, I have juste 2 warning about incompatible pointer types. But until now it worked anyway.

    I haven't specific characteres or spaces, only uppercase and lowercase letters, numbers and "_".

  • I have created a new post about this warning. I don't understand why these pointer to function gives me this warning.

    =>

    Ce message a été modifié par: guillaume clairet

    It compiles without any warning now.

    Thanks.

  • Does the project show the same behaviour if you copy it to a different computer?

    If so could you provide the project to Renesas?

  • I tested it with my colleague's computer and it doesn't work either.

    Could you give me an email address to send my project ?

    Thanks.

  • No email address ?

    Thanks.

  • If you don't have a Renesas contact you could send the project to, you could send a message via Rulz.

  • I'm really stupid !

    When I changed the "-debug" option in category "Output" on the linker tab in the toolchain settings window, I changed it for an other configuration in the toolchain configuration window.

    Thank you very much for your help and time you spent.