Hew RX63N project debug console windows 10

We have a project using an RX63N specifically an R5F563NF variant using KPIT 12.03 and an E1

 

We use the HEW debug console sometimes when debugging the system and this worked fine on windows 7. This functionality appears not to be working on windows 10.  Has anyone experienced this issue

Here is how we write to the debug console in the APP. The NF variant of the processor is quite new and we needed a processor definition file update to support it.  

 

while( *pDBGSTAT & CheckBit ) // Wait until bit 8 of DBGSTAT is 0
{
__asm volatile("NOP"); 
}
*pFC2E0 = u8Character; // Write one character to FC2E0

 

Paul

  • Hi Paul,

    Were you able to resolve the issue? This could be an OS compatibility issue, though I'm not sure. Let's wait until other members confirm about this one.

    JB
    RenesasRulz Forum Moderator

    https://renesasrulz.com/
    https://academy.renesas.com/
    https://en-us.knowledgebase.renesas.com/

  • I don't think it is an Windows issue.
    I tried debug console with
    - Windows 10 Pro Version 1709
    - HEW V.4.09.01.007
    - KPIT GNURX 13.01
    - RX E1 debugger software 1.03.00
    - RX62N8 processor.

    In my example the debug console shows all expected outputs.
  • In reply to FrankL:

    We have window pro version 1803. I wonder if that has anything to do with it, I will see if I can get it rolled back to 1709. The only other thing is the MCU definition files, I manually created a definition for the NF variant whereas the others used a Renesas supplied patch to provide support.

    Paul.
  • Hi,
    same problem here. The debug console is working fine on windows 7 and on windows 10 it is not working.
    - Windows 10 Pro Version 1803
    - HEW V.4.09.01.007
    - KPIT GNURX 14.03
    - RX E1 debugger software 1.03.00
    - RX63N processor.

    Are there any solutions to this issue yet?

    Best regards
    Jan
  • In reply to JK:

    I think the best solution would be to switch to e2 studio as IDE.
  • Paul,

    Have you found a working solution for your debugging console?

    Mike Clements
    RenesasRulz Moderator
  • In reply to Mike Clements:

    No we have had to give up on this as a lost cause and start a port to e2studio

    Paul
  • In reply to Mike Clements:

    Yes, last week we figured out a solution but is some kind of workaround. We are using now with a virtual machine, which is simulating the before used windows 7 environment. In the VM everything is working as expected.

    Jan