GR LYCHEE WiFi modem is not MAC and IP address.

 I tried the following example in Offline IDE but my Wifi Module is not responding.

http://gadget.renesas.com/en/product/lychee_sp/4.html

How can I troubleshoot ESP32 wireless module?

Or can anyone support me with the BIN files for flashing to ESP32?

  • Hi,

    If you are concerning that MCU could communicate with ESP32, try below bridge code.

    You can confirm communication with ESP32 using AT commands via serial monitor.

    Refer to below about AT commands.

    github.com/.../ESP32_AT_Commands_Set.md

     

     

    #include <Arduino.h>

    void setup() {
    Serial.begin(115200); // for PC
    Serial2.begin(115200); // for ESP

    pinMode(PIN_ESP_EN, OUTPUT);
    pinMode(PIN_ESP_IO0, OUTPUT);
    pinMode(PIN_SW0, INPUT);
    pinMode(PIN_SW1, INPUT);
    digitalWrite(PIN_ESP_IO0, HIGH);
    digitalWrite(PIN_ESP_EN, HIGH);
    }

    void loop(){
    if(digitalRead(PIN_SW0)){
    digitalWrite(PIN_ESP_EN, HIGH);
    } else {
    digitalWrite(PIN_ESP_EN, LOW);
    }
    if(digitalRead(PIN_SW1)){
    digitalWrite(PIN_ESP_IO0, HIGH);
    } else {
    digitalWrite(PIN_ESP_IO0, LOW);
    }

    if(Serial.available()){
    Serial2.write(Serial.read());
    }
    if(Serial2.available()){
    Serial.write(Serial2.read());
    }

    }
  • In reply to Okamiya Yuuki:

    Thank you.
    I tried ESP32-WROOM-32 AT Bin V1.1.2 for Flash writing/evaluation of ESP32. Now I'm trying to change the SSID and password of the EPS32 modem by using the simple example program and it is not responding and I think that RZ/A1LU is not detecting the ESP32 Modem. Please Guide me to re establish the communication between RZ/A1LU and ESP32 Modem in GR LYCHEE board.
  • In reply to Ozil:

    Hi,

    If you could do AT commands communication, there seem to be no problem with your ESP32.

    I tried again web camera example as you mentioned and that works fine.

    Could you share your screen cature ? I'm not sure what you did. 

     

      

  • In reply to Okamiya Yuuki:

    Thank you.

    This is the output I'm getting after running this program.

  • In reply to Ozil:

    I tried this code,
    I would suggest you to check your router NSAPI_SECURITY_WPA_WPA2 type, it might be WEP security
    also check the connect function, it is returning an integer as return value so you can get the error code in print statement.
    This happens usually when access point is not connected properly for user id and password, may be user ID and password is correct but sometime strength is also factor for delay in connect it will return that value.

    Regards,
    Ritesh
  • In reply to RiteshGohil:

    Thank you, I checked the connect function and its returning non zero. ie; its not connecting.
    Only one time I got MAC address once while running this code.
    I will check the router NSAPI_SECURITY_WPA_WPA2 type.
  • In reply to Okamiya Yuuki:

    Available Wifi is shown as given in the image.

    I flashed ESP32 with ESP32-WROOM-32 V1.1.2 downloaded from EXPRESSIF website and that's why GRLYCHEE it is not detecting ESP32.

    Can you give me the AT files for GRLYCHEE. ie  

    0x1000:bootloader.bin
    0x4000: partitions_singleapp.bin
    0x10000: .bin

  • In reply to Ozil:

    I think you understand, modify SSID and PW corresponding to your access point.
  • In reply to Okamiya Yuuki:

    The output of the code is shown in the image.