i am having Gr-Lychee i would like to test the camera with GR-lychee and i have used the displayapp and the following code

// Sample for GR-PEACH, GR-LYCHEE
// Required hardware: Camera, USB
// Public Domain

#include <Arduino.h>
#include <Camera.h>
#include "DisplayApp.h"
Camera camera(640, 480);
//Camera camera(640, 480, 0); // specify 0 for CVBS with GR-PEACH
//Camera camera(640, 480, 2); // specify 2 for Wireless Camera shield
static DisplayApp display_app;

void setup() {




void loop() {
display_app.SendJpeg(camera.getJpegAdr(), (int)camera.createJpeg());

after fusing the code 

i connect the usb0 to my laptop and i am getting CDC device driver not installed.


how could i rectify the problem

    What is a Windows Driver
    First of all, you need download the latest drivers file.

    If it is a executive file, you can install it by simply double clicking the file.

    If it is a zip file and you can not find a installer in the archive, you can install the driver by following instruments below:

    1. Go to Control Panel and open Device Manager.

    2. Find the device that your are trying to install a driver

    3. Right click the device and select properties.

    4. Select Driver tab, then click the Update Driver button.

    5. Choose Browse my computer for driver software.

    6. Let me pick from a list of device drivers on my computer

    7. Browse for the .inf driver file. Open and Next.

    8. The driver will be installed.

    i have followed the above steps to install the USB CDC device driver in my laptop
  • In reply to vairamani:

    If you are using Windows 7 or 8, you need to install USB driver as following web site.
    There is no problem with Windows 10 or Mac OSX for using USBCDC.

    Please refer to the part of DisplayApp in the following product page.
    Described as following.
    "Installing the USB driver is required on versions earlier than Windows 10."
  • In reply to Okamiya Yuuki:

    The drivers for GR lychee are provided on the gadget renesas page.Im using windows 8.1 and when i installed the drivers, the system recognizes only mbed port and USB0 is not working.I tried reinstalling the driver but thats not worked.The i tried connecting lychee on another system and it recognized it as teensy. So i downloaded teensy USB driver on my laptop after uninstalling previous drivers and it worked.If you have similar problem try installing teensy usb driver