e2studio

I want to use e2studio for developing the code for Gr krade Board & i installed the same in PC, while developing a program in it & building it it is showing some errors linke make file error etc. Can any one guide me how to use it. any user manual / procedure of how to use it.

Thanks in advance.

Parents Reply Children
  • I FOLLOWED AS PER THAT PROCEDURE IT IS SHOWING THE FOLLOWING ERROR

    " Program "make" not found in PATH

    PATH=[D:/eclipse//features/com.renesas.jre.win32.win32.x86_1.8.0.40/jre/bin/client;D:/eclipse//features/com.renesas.jre.win32.win32.x86_1.8.0.40/jre/bin;D:/eclipse//features/com.renesas.jre.win32.win32.x86_1.8.0.40/jre/lib/i386;C:/Users/Dell/AppData/Local/Temp/7zSB486.tmp/jre/bin/client;C:/Users/Dell/AppData/Local/Temp/7zSB486.tmp/jre/bin;C:/Users/Dell/AppData/Local/Temp/7zSB486.tmp/jre/lib/i386;C:\ProgramData\Oracle\Java\javapath;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files (x86)\iis express\PHP\v5.6;C:\Program Files (x86)\iis express\PHP\v5.4;C:\Program Files (x86)\iis express\PHP\v5.3;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static;C:\Program Files (x86)\Skype\Phone\;D:\cylon\;C:\Users\Dell\AppData\Roaming\npm;C:\Program Files (x86)\Microsoft ASP.NET\ASP.NET Web Pages\v1.0\;C:\Program Files\Microsoft SQL Server\110\Tools\Binn\;C:\Program Files (x86)\Windows Kits\8.1\Windows Performance Toolkit\;C:\Program Files (x86)\Microsoft SDKs\TypeScript\1.0\;C:\Program Files\Microsoft SQL Server\120\Tools\Binn\;G:\mat\runtime\win64;G:\mat\bin;C:\Program Files\MATLAB\MATLAB Compiler Runtime\v82\runtime\win64;C:\Users\Dell\AppData\Local\Temp\7zSB486.tmp;;C:\Users\Dell\AppData\Local\Temp\7zSB486.tmp;]

    "

  • Could you confirm properties to click [Project] -> [Renesas Tool Setting]  and [environment] in property ?

    The below is my setting in Japanese, but you can see [PATH]. A make(nearly build) depends on [PATH] setting.

    I think you've not finished installing GNURX. My setting in [PATH] is below:

    C:\PROGRA~1\KPIT\GNURXV~2.03-\rx-elf\rx-elf\bin;C:\PROGRA~1\KPIT\GNURXV~2.03-\rx-elf\rx-elf\rx-elf\bin;C:\PROGRA~1\KPIT\GNURXV~2.03-\rx-elf\rx-elf\libexec\gcc\rx-elf\4.8-GNURX_v14.03;C:/Renesas/e2_studio_v4/Utilities;C:/Renesas/e2_studio_v4/eclipse//features/com.renesas.jre.win32.win32.x86_1.8.0.40/jre/bin/client;C:/Renesas/e2_studio_v4/eclipse//features/com.renesas.jre.win32.win32.x86_1.8.0.40/jre/bin;C:/Renesas/e2_studio_v4/eclipse//features/com.renesas.jre.win32.win32.x86_1.8.0.40/jre/lib/i386;C:\Program Files\Common Files\Microsoft Shared\Microsoft Online Services;C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files\PHP\;C:\Perl\site\bin;C:\Perl\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files\Microsoft Application Virtualization Client;C:\Program Files\Microsoft SQL Server\110\Tools\Binn\;C:\Program Files\Windows Live\Shared;C:\Ant\bin;C:\Java\jdk1.7.0_25\bin;C:\Program Files\Launch4j;C:\cygwin\home\a5034000\rl78flash-master;C:\Program Files\Pico Technology\PicoScope6\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0;C:\MinGW\bin;C:\MinGW\MSYS\1.0\bin;C:\Qt\4.8.5\bin;C:\Program Files\TortoiseHg\;C:\Renesas\e2_studio_v4\eclipse