e2Studio 2021-01 Builds don't actually clean anymore?!


Recently move to the 64Bit e2studio: Version: 2021-01 (21.1.0) Build Id: R20201211-1358

Previous version: Version: 7.8.0 Build Id: R20200321-2326

Previously performing a clean build all the objects were deleted compiled everything new. Now clean behavior only builds recently updated file. Unless I missed something this means clean is completely broken. To get successful clean builds I am back to deleting the entire target build folders and ignoring the warnings that accompany that. Will this be fixed or is there some other way to handling this?

Best Regards,


  • Have you tried the latest 2021-04 version?

  • How can I do an upload of the generated makefile? Tried twice to paste it here and was rejected for review. I can't find where to do an upload? 

    Please Advise.

  • I did the update and behavior is the same. My build go straight to link, nothing is deleted at all.

    (strange I already responded with this however it didn't show up here)

  • When evoking a clean only. I get 87 ignored errors. 

    Extracting support files...
    15:11:05 **** Clean-only build of configuration HardwareDebug for project CMXU_Gauge ****
    make -j4 clean
    rm -rf *.sni *.dbg *.lst *.lis *.lpp *.map *.x *.lbp *.bls *.libelf *.rel *.lbk *.abs *.mi *.jmp *.fsy *.ud *.udm 1st/*.abs 1st/*.jmp 1st/*.fsy CMXU_Gauge.abs CMXU_Gauge.lib CMXU_Gauge.mot
    rm -rf Software/Application/uCOS-III-USBD-V4/BSP/Init/dbsct.obj Software/Application/uCOS-III-USBD-V4/BSP/Init/idcode.obj Software/Application/uCOS-III-USBD-        .... huge list of stuff to delete....


    make: [clean] Error 87 (ignored)
    rm -rf Software/uC-CPU/*.asm Software/uC-CPU/*.p Software/uC-CPU/*.pp Software/uC-CPU/*.src Software/uC-CPU/*.jmp Software/uC-CPU/*.lst Software/uC-CPU/*.prn Software/uC-CPU/*.i Software/uC-CPU/*.ud
    rm -rf Software/Application/BSP/*.asm Software/Application/BSP/*.p Software/Application/BSP/*.pp Software/Application/BSP/*.src Software/Application/BSP/*.jmp Software/Application/BSP/*.lst Software/Application/BSP/*.prn Software/Application/BSP/*.i Software/Application/BSP/*.ud                 ....etc....then

    ECHO is off.
    'Clean complete.'

    15:11:06 Build Finished. 0 errors, 0 warnings. (took 747ms)

  • Yes I updated to 2021-04. The problem is still there. Can anyone offer guidance for a workaround?

  • You could add debug option and see what's going on in make command.
    In project property dialog, open "Builder Settings" tab in "C/C++ Build" category, then uncheck "Use default build command".  Then add an option in the "Build command" EditBox  for example "make --debug=a -j4".
    (You can skip reading implicit messages since it is too long.)

    For the details about GNU make and the options, see the following page.

    Even only clean, you would not able to see all messages in build console.
    Look at the build log in the current workspace. See the following FAQ to find the location of build log.

  • Okra,

    Seems there in no 'clean' target and wants to recreate the makefile. Then he creates a rm argments list that is huge and that fails leaving all objects untouched.

    How do we fix this?

  • Got a debug build  log. Can't paste the excerpts here. Some of the lines are too long I guess. Don't see a way here to upload any kind of file from the hard disk. How can I show the error entry logs?

  • > Then he creates a rm argments list that is huge and that fails leaving all objects untouched.

    Do you mean command line is too long (how long was the rm line?) and not accepted by Windows??

  •  Clean for this identical project completes no errors in the 32bit e2studio 7.8.0.

    The command is 80579 byte long and Starts out:

    rm -rf *.sni *.dbg *.lst *.lis *.lpp *.map *.x *.lbp *.bls *.libelf *.rel *.lbk *.abs *.mi *.jmp *.fsy *.ud *.udm 1st/*.abs 1st/*.jmp 1st/*.fsy CMXU_Gauge.abs CMXU_Gauge.lib CMXU_Gauge.mot

    Creates a huge list:

    rm -rf Software/Application/uCOS-III-USBD-V4/BSP/Init/dbsct.obj Software/Application/uCOS-III-USBD-V4/BSP/Init/idcode.obj Software/Application/uCOS-III-USBD-V4/BSP/Init/sbrk.obj  Software/uC-CPU/cpu_core.obj  Software/Application/BSP/bsp.obj                                                      ....etc...

    Finishes with:

    ....massive list....         Software/uCOS-III/Source/os_task.d Software/uCOS-III/Source/os_tick.d Software/uCOS-III/Source/os_time.d Software/uCOS-III/Source/os_tmr.d Software/uCOS-III/Source/os_var.d Software/Application/BSP/EEFlash/EEFlashUpdate.d Software/Application/BSP/EEFlash/r_flash_api_rx.d, ...) failed.

  • How about clean in newly created projects?
    What if moved workspace/project folder to other location (such as C:\wks)?

  • I move my project elsewhere, deleted his .metadata folder, then imported my project to the IDE. Same behavior. Location of new .metadata is D:/TestCode/CMX_Gauge 

    Then I deleted the .cproject file, and imported as an archive. This would build by the hammer button only with some errors. Project clean did nothing at all.

  • OK seems 64bit e2studio is not ready with full support. Looks like a worthy upgrade but not just yet. I'm going back to 32bit 7.8.0. Will wait for 64bit to mature before he become my main tool.

    Thanks Okra