RX65N CAN random error



I run my RX65N (DATASHEET: https://www.renesas.com/us/en/search/keyword-search.html#q=r01an2472&genre=sampleprogram&rows=20) in 10 ms cycles. Every cycle it has to send a few CAN Messages. I control the result with a USB-CAN Reader.

For the CAN Setup i am using a TJA1051/3 and for the Software the CAN-API from Renesas (https://www.renesas.com/us/en/search/keyword-search.html#q=r01an2472&genre=sampleprogram&rows=20).


The Problem I am facing is, that I got an ACK error or a Stuff Error and a recessive flag error.

The Timings should be fine and the physical can bus too. other devices are working fine.


In my Software I run R_CAN_Create(); R_CAN_PortSet(); R_CAN_TxSet(); The dataframe is Setup correct.

In the loop I run R_CAN_TxStop(); and R_CAN_TxSet(); to send the Messages.


Receiving Messages works find.


Can anyone tell me where the Problem could be? Software or Hardware?


Sincerely yours



  • Good day, Erik!

    Have you found a solution to this issue? I found some app notes (RX Family, Can Controller) that might be of use to you. Those documents contain informations regarding the errors you have mentioned. I hope you can find something in there.

    Best regards,
    RenesasRulz Forum Moderator

  • In reply to Sai:

    Hi Sai!

    I appreciate your quick Response. The given links gave me a few Points to double check. Sadly, Nothing worked. I looked for the ISO 11898 to find out where the error comes from.

    I mostly got the recessive bit error and stuff error --> seems the bit Timings are a bit off. but 95% of the time the message gets through. So I can't be too much of with them. My fCAN is 60MHZ, my BRP is 8, TSEG1=12 TSEG2=2 SJW=2. This should give me a sample Point at ~13 tq.

    Could it be, that there is some Kind of power safing in the Background that is Messing with PCLKB in some way?
    Sadly I am unable to messure the Datalines, so I can't simply check it.

    Best regards,

  • In reply to MrF:

    Hi erik,

    Did you made some progress on this at this time?

    RenesasRulz Forum Moderator

  • Hi Herald,

    I tried the same Software on another eval board and everything worked fine. So I guess I kinda broke my old one.
    Problem solved I guess :)
    Thanks for the effort

    Best regards, Erik