IAREW RL78 Version 4.10 BLE Simple project faild to compile

Hello Experts,

We have the latest version of IAREW RL78 V4.10. Tried to compile simple BLE project but got the linker errors

Error[Lp011]: section placement failed  

 unable to complete "place at" directives with a total estimated minimum size of 0x7c bytes in <[0x4-0x53]> (total space 0x50).

Error[Lp015]: section placement failure: overcommitted content in [0x4-0x53]

Error while running Linker

I am using BLE version (BLE_Software_Ver_1_21). There are library files in the project and I think these libraries are compiled with IAREW RL78 V2.0. And it can not be compiled with the latest version of IAREW therefor linker error is generated. It is difficult to find an old version on the IAREW on the website of IAR. Can someone please update the project so that it can be compiled with the latest version of IAREW RL78. Libs included in the projects are attached in the following picture.

Looking forward to hearing from you soon. 

Best Regards,

Abdul Sattar

 

 

  • Hello,
    unfortunately I have no idea what you mean by "simple BLE project".
    The error message is not related to the library being compiled with a different compiler. The error message says it cannot place a section at the location defined in the linker script file because there is not enough space.
  • In reply to FrankL:

    Dear Frankl,

    Thank you very much for your reply. I can not compile "project_simple" in the directory of "BLE_Software_Ver_1_21" with version V4 of IAR for RL78. I have specified the linker available in the "config" folder inside "project_simple" in IAR linker option.

    When I compile it says that linker file mismatch. Can you please compile on your side with IAREW RL78 Version 4. I have tried a lot and have been struggling for a week but not a success.

    I have attached screenshot of error please check.

    Luckily I found, with many efforts, version 2 of IAREW RL78 (30 days evaluation version). And the project compiles correctly with Version 2 without any modification. The problem with version 2 of IAREW RL78 is that it does not support E2-lite version emulator and we do not have a license too, at the moment we do not have E1 emulator that is supported in version 2 of IAREW RL78. With us right now available emulator is E2-Lite so cannot test or debug the project. I have attached the screenshot that compiles correctly with some warnings. 

    Please help us fix the problem of compilation with version 4 of IAREW RL78.

    best Regards,

    Abdul Sattar