Failed to read license file with SSP 1.4.0 upgrade

I just upgraded SSP from1.3.0 to 1.4.0.  I generated and downloaded a new license file.  I then pointed e2studio to my newly downloaded .xml file via Help / Synergy License (note I place the license files in a different folder than the e2studio default).

But when I build my project, I get "ERROR: Failed to read license file" on the dave2d files.

The Dave/2d component is listed on the Synergy License file screen of e2studio as follows:

Component: TES D/AVE 2D Graphics Driver
Permissions: Source=no,Edit=no,Save=no,View=yes,Compile=yes

How can I fix this error?

Thanks,

Jeff

  • Because I was also having some other issues with the e2studio upgrade (related to the RX compiler) I decided to uninstall e2studio and SSP 1.4.0 and try again.  However this time I did not use the Package Installer but instead manually installed e2studio and then SSP 1.4.0 using the Standalone installers.

    Now I am no longer getting the "ERROR: Failed to read license file" but am instead getting "ERROR: Failed to read file: arm-none-eabi-gcc" error when I Build my Synergy project:

    Jeff

  • In reply to JeffP:

    I solved the issue by going to Project / Properties / C/C++ Build / Settings / Toolchain and then changed nothing but just hit Apply. Now the project compiles with no errors.
  • In reply to JeffP:

    After a number of dead ends, opening this menu and hitting "Apply" fixed my build. FWIW, I was able to build my code in a .../branches/... path, but I got the error above after merging to .../trunk/... and could not build even though the code, configuration.xml, and whatever else is checked in was identical. At this point I'm guessing there is something that either should or should not be checked in.

    Thanks,
    Matt Farley