Cannot launch debug session to RX64M with e2studio/e2lite debugger

I compiled a basic project for Renesas RX64M with the latest v15.02 RX GNU toolchain. IDE is e2studio v4.3.0.007, running on Windows 10. The .x file is generated and available.

When I connect to e2lite debugger, I obtain the following error message that I fail to interprete: "Error in final launch sequence". Right before downloading the code to the processor, the target connection quits.

GDB settings are mostly as default, local GDB server autostart, port=61234, adm=61236. I use JTAG, self-powered target board, single-chip mode, little-endian, main EXTAL 12 MHz.

I join a screenshot with the relevant error message. 



I have checked the electrical connections between the e2lite and the target board, and they seem fine. MD/FINED pin is high. The reset pin can be pulled low/high by e2lite.

I have also managed to program my project's .mot file with Renesas Flash Programmer 3 through the e2lite. That worked fine. The only issue I have is when I want to launch a debug session from e2studio, with e2-server.gdb.exe/rx-elf-gdb.exe and the e2lite debugger.

Upon another recommendation, I have checked if there is a problem with the Windows Firewall. Connections for e2-server-gdb.exe are all enabled. I do not believe in a problem here.

It would be of great help if you can point me to a solution. Thanks a lot in advance. 

  • I realize that the quality of the screenshot I sent is bad.

    The exact failure message is the following:

    Failed to execute MI command:

    target extended-remote-rx localhost:61234

    Error message from debugger back end:

    localhost:61234: The system tried to join a drive to a directory on a joined drive.

  • In reply to Severin Leven:

    Severin,

    Have you checked that your your usb drivers are up to date?

    Mike Clements

    RenesasRulz Moderator

  • In reply to Mike Clements:

    Hi Mike,

    thanks for your reply. The usb drivers came with the latest distribution of e2studio (v4.3.0.007), so they are supposed to be up to date, I guess.

    Anyway, I have news: in a way they are good and bad at the same time:

    Good: it works now, I can launch a debug session, e2studio communicates with the RX64M on my custom board through e2lite. I am quite satisfied.

    Bad: I have no idea why it started working all of a sudden. I am absolutely sure that I have not made any changes to the setting of the e2lite debugger, e2-server-gdb.exe/rx-elf-gdb.exe in e2studio, nor to my hardware or JTAG wiring.

    As I said above, I programmed my board several times with Renesas Flash Programmer v3 through the e2lite, which always worked fine. That is about when the debug session started to work as well. However, I cannot say how events are related and unfortunately, I have no clear recommendations to give to anyone having the same problem.

    Best,

    Severin

  • In reply to Severin Leven:

    Severin,

    By chance when the system started working again did you create a new debug configuration thru e2Studio (Run->Debug Configuration...)? Also, I'm curious if there was an issue with the e2lite. Did you happen to (or have access) to an E1 debugger? The e2lite is a new debug hardware platform from Renesas and I'm wondering if it could have been the issue? Just my thoughts here...

  • In reply to twelvexs:

    Hi twelvexs,

    no issues that I can tell of with the e2lite. Currently, it works great.

    And regarding the debug configurations, I believe that I created my project from the start with a "HardwareDebug" and a "Release" configuration (probably the default settings for a new project). Afterwards, I have neither removed nor added any configuration manually.

    My "HardwareDebug" configuration is under "Renesas GDB Hardware Debugging" in the "Debug Configuration" window. I took some screenshots of the Debugger settings:

    Best regards,

    Severin