when will debug "step over" function actually be made to (finally) work??

I've been using E2 studio from version 7.5 through 7.8, and in none of them does the debug "step over" function actually work. It ALWAYS steps INTO the instruction. This is maddening in trying to debug code of any length. 

My question is: WHEN will this be FIXED FINALLY?

I have been reading of others who have this issue, from as far back as V7.5 / V7.6. Before that, this function might have worked.

Having this severe handicap makes debugging of code very, very lengthy and very incomplete and virtually impossible to do. I would have thought that Renesas would have figured this out by now after, how many?, releases, and yet...not hardly.

I am working currently with V7.8 and i am running on Windows 7 SP1. Yes, i know that Win 7 is only officially supported up to V7.6 (which is also broken vis-avis debug "step over"), but i would wager that there are still many, many developers out there who are still using Win 7 and have not moved onto Win 10 and probably won't because of other development software that will only run on Win 7 or 8.

When (???) will Renesas finally issue an update to fix the debug "step over" issue? AND will they fix it for people still on Win 7?


  • Hi norberto pellicci,

    I'm using the 2020-10 version and the step function just works fine. But yeah, maybe it's because I'm using windows 10. I'm not sure if the devs prioritizes the fix on this issue for windows 7 because since Jan 16, 2020, they have already ended the evaluation and the guarantee of operation under Windows 7.

    RenesasRulz Forum Moderator


  • Hi Noberto-
    Check your compiler optimization setting in your project (right click) Properties>C/C++ Build->Settings, Tool Settings tab, Compiler->Optimizations. Make sure they are turned off, otherwise stepping will follow where the optimized code is relocated to which makes things look broken. Stepping works fine for me on Windows 7 and 10 using e2studio v7.x with compiler optimizations off.
  • In reply to aetherengineer:

    Hi, thank you for your input. I already have compiler optimization off and I've always had it off. The step-over function has never worked for me, always stepping into the instruction. I'm curious what other settings you have that allow your debug code to step over rather than into the instruction. By the way, just to be clear, i can step from instruction to instruction (ie: into), but never step over.

  • In reply to norberto pellicci:

    Which MCU are you using?
  • In reply to JB:

    Thanks JB, but unless the 2020-10 version works on Win 7, then it really is of no use. I don't plan on upgrading my development system to Win 10 any time soon. So what's the solution? The V7.x versions were around for a long time with Win 7 but Renesas, for whatever reason, didn't fix this bug. I know it's been a known issue in these versions, so i'm really miffed that Renesas has abandoned the Win 7 developers. Is there any workaround to actually get the step-over function working under Win 7? Is there a patch? Or has Renesas totally abandoned Win 7 users?
  • In reply to aetherengineer:

    I'm using R5F5630ACDFB#V0 (R5F5630A)
  • In reply to norberto pellicci:

    Ah. That's an older part. This is a longshot thing to check- In your Debug Configuration, go to Debugger tab, Debug Tool Settings tab, under System, make sure that allowing writing to program/code flash is enabled. Stepping functions use breakpoints internally. I know the RX64M will not debug properly without this feature enabled (most MCUs don't require this), but I suspect your problem is due to something other than that. Still, it's worth a try.
  • In reply to aetherengineer:

    Thanks AE, it was a good suggestion, but unfortunately it doesn't work with step-over. It was definitely worth a try. Again, thanks for your help. Do you have any other thoughts on this?

  • In reply to norberto pellicci:

    Well, when in doubt, upgrade. I know the latest e2studio is not vetted for Windows 7 use, but I suspect it would work fine (at least worth a try). You can install it to a different path. Keep in mind that e2sutdio is built upon eclipse, and any bugs in eclipse trickle through to e2studio. I recently moved to Windows 10 and use MCUs more recent than yours, so fortunately I do not see any of the problems you do.
  • In reply to aetherengineer:

    Upgrading does not help. The latest 2020-10 one has the same problem with debugging after run was stopped at breakpoint. This bug is observed beginning with 7.6.0 - on times when Windows 7 was still supported. So I tend to consider it unrelated to W7 - W10 differences.