After upgrading to 7.6.0 debugging with "Step Over" is not fully functional.



Good morning, All!


Last Weekend I have updated my E2 Studio  version 7.5.0 to version 7.6.0 and observed the following issue: During debugging after breakpoint event the "Step Over" function is processed as "Step Into" one (entering into called function code). The "Step Return" is also handled as "Resume" and do not allow to continue debugging on the caller's level.

Note that "Step Over" in main() function during the debugging session start is working OK - i.e do not entering into called functions code.

Rolling back from 7.6.0 to 7.5.0 fixes the issue.

We are working with RX platform, using Renesas E1 Emulator and GCC toolchain for compiling the aplication.


Has anybody observed the same issues? Are there any settings to fix it for 7.6.0?


Thank you, and have a nice Week!

  • I can confirm the issue with Version: 2020-04 (20.4.0), Build Id: R20200412-1149.
    We have to use version 6.3 for debugging.

    Re-creating the workspace did not help.

    We would like to upgrade our development environment but this issue is a blocking point!
  • In reply to Kernwein:

    Hi.

    That is strange. After upgrading to the same 2020-04 version from 7.5.0 without recreating workspace I do not observe this issue at the moment.
  • In reply to siarzhuk:

    Our problem with version 2020-04 is solved.
    With the Renesas support team we found the reason for the issue: we use our own make environment which invokes the "DWARF converter tool" to generate the .x file. We did not update this converter tool (v2.4.10) and the generated .x file was incompatible to the rx-elf-gdb used by e2studio 2020-04. Updating the tool to the version v2.4.15 (supplied with e2studio 2020-04) solved our debug issue.
  • Dear Colleagues,

    any news on the problem? Do you still observe it with the latest versions of E2 Studio? There is yet another discussion about the problem : renesasrulz.com/.../when-will-debug-step-over-function-actually-be-made-to-finally-work - and some tends to consider, that it may be Windows 7 related issue. What is your working environment now?

    I still observe it with the latest 2020-10 version of E2 Studio.

    Thanks in advance and have a nice Weekend!